Project

General

Profile

Bug #1291

missing extra_version/patches/ in lttng-modules-2.12.{2|3}).tar.bz2

Added by He Zhe 2 months ago. Updated 20 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
11/23/2020
Due date:
% Done:

0%

Estimated time:

Description

In the following tarballs there is no extra_version/patches/ directory which is expected by scripts/extra-version-patches.sh
https://lttng.org/files/lttng-modules/lttng-modules-2.12.2.tar.bz2
https://lttng.org/files/lttng-modules/lttng-modules-2.12.3.tar.bz2

This would cause a bunch of the following build errors.
lttng-modules/2.12.2/build/extra_version/patches/: No such file or directory

#1

Updated by He Zhe 2 months ago

This should be due to .gitignore including extra_version/.

#2

Updated by Mathieu Desnoyers 2 months ago

Indeed, when I create the tarballs, my script copies the git repository and issues "git clean -xdf" to only keep files tracked by git.

So having extra_version/ in .gitignore causes my tarball creation script to disregard this directory and its contents entirely.

So one approach would be to remove extra_version/ from .gitignore. Another approach would be to change my script so it re-creates those directories after the clean.

Michael, any preference ? What is the intent for having extra_version/ in .gitignore ?

#3

Updated by Michael Jeanson 2 months ago

Both directories contain a 'README' file because git can't track an empty directory, 'git clean -xdf' will not delete them since they are part of the repo, if the script you use to generate the tarballs delete them, it is clearly broken.

#4

Updated by Michael Jeanson 2 months ago

Looking at the tarball, 'extra_version/README' exists but not 'extra_version/patches/README', there is something fishy happening here.

#5

Updated by Mathieu Desnoyers 2 months ago

The issue is with my release script.

#6

Updated by Jonathan Rajotte Julien 20 days ago

  • Status changed from New to Resolved

Also available in: Atom PDF