Project

General

Profile

Actions

Bug #1332

closed

LTTng-UST requires glibc >= 2.16 to build

Added by Sergei Dyshel about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
11/25/2021
Due date:
% Done:

0%

Estimated time:

Description

There is "static_assert" macro used in the code, which is only supported in glibc's "assert.h" header starting from version 2.16.
According to this page https://gcc.gnu.org/wiki/C11Status.

Please state this requirement in README or use more portable "_Static_assert" macro.

Actions

Also available in: Atom PDF