Project

General

Profile

Actions

Bug #626

closed

assertion in libust cause application to quit

Added by Yannick Brosseau almost 9 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Target version:
Start date:
09/05/2013
Due date:
% Done:

0%

Estimated time:

Description

I'm instrumenting RSyslog and I sometime get the following output and assert:

libust[4357/4358]: Error: sendmsg: Socket operation on non-socket (in ustcomm_send_unix_sock() at lttng-ust-comm.c:332)
libust[4357/4358]: Error: Socket shutdown error (in ustcomm_send_unix_sock() at lttng-ust-comm.c:339)
libust[4357/4358]: Error: Error handling message for global socket (in ust_listener_thread() at lttng-ust-comm.c:1087)
libust[4357/4358]: Error: recvmsg: Socket operation on non-socket (in ustcomm_recv_unix_sock() at lttng-ust-comm.c:285)
libust[4357/4358]: Error: Socket shutdown error (in ustcomm_recv_unix_sock() at lttng-ust-comm.c:292)
libringbuffer[4357/4358]: Error: close: Bad file descriptor (in shmp_object_destroy() at shm.c:414)
rsyslogd: shm.c:415: shmp_object_destroy: Assertion `0' failed.


This happens when I issue a lttng stop command.
It also shows sometime when I try to start the application.

I run the app with the following command:
LD_PRELOAD=liblttng-ust-fork.so /usr/local/sbin/rsyslogd

I did not see the problem when I run in rsyslog non fork mode.

Currently running both 2.3 for lttng-ust and lttng-tools. Same problem was happening on 2.2


Related issues 1 (0 open1 closed)

Is duplicate of LTTng-UST - Bug #253: lttng-ust file descriptors can be closed by "misbehaving" daemon appsResolved06/05/2012

Actions
Actions

Also available in: Atom PDF