Project

General

Profile

Bug #10

tor instrumentation only works partly

Added by Mathieu Desnoyers over 8 years ago.

Status:
Resolved
Priority:
Critical
Target version:
-
Start date:
02/09/2012
Due date:
% Done:

100%

Estimated time:
3.00 h

Description

When instrumenting tor, only some of the tracepoints are fired, event though all events are enabled.

(skipping bug reproduction details, since the bug is already solved)

Solved by commit:

commit 51920067af7b1049413c1b8c30ee254afbd4e448
Author: Mathieu Desnoyers <>
Date: Thu Feb 9 18:55:44 2012 -0500

Fix tracepoint.h multiple .o within module/core exec linkage bug
We need all symbols looked up with dlopen to share the same linkage
property as the __tracepoint_registered variable (shared across .o in a
module/executable), otherwise only the first .o which runs its
constructor will have those defined.
Caused some tracepoints not to be traced in non-_LGPL_SOURCE
applications, due to the check:
if (!TP_RCU_LINK_TEST())   \
return;
Signed-off-by: Mathieu Desnoyers &lt;&gt;

No data to display

Also available in: Atom PDF