Project

General

Profile

Bug #100

After sessiond major failure (e.g. segfault), new sessiond hangs on previous consumer

Added by Mathieu Desnoyers about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
02/23/2012
Due date:
% Done:

0%

Estimated time:

Description

how to reproduce:

killall -9 lttng-sessiond

restart sesssiond

send commands to sessiond that require it to spawn the consumer.

It will hang for 30 seconds waiting on the previous consumer:

compudj@thinkos:~$ ps aux |grep lttng
root 29577 0.0 0.0 230296 1256 pts/0 tl+ 17:15 0:00 lttng-sessiond -vvv
compudj 29589 0.0 0.0 31444 1104 pts/6 S+ 17:15 0:00 lttng enable-channel test -u --num-subbuf 3
root 29591 0.0 0.0 72192 744 pts/0 Sl+ 17:15 0:00 lttng-consumerd --quiet -u --consumerd-cmd-sock /var/run/lttng/ustconsumerd64/command --consumerd-err-sock /var/run/lttng/ustconsumerd64/error
compudj 30511 0.0 0.0 112548 868 pts/9 S+ 17:26 0:00 grep lttng
root 32255 0.0 0.0 68052 712 ? Sl 14:50 0:00 lttng-consumerd --quiet -u --consumerd-cmd-sock /var/run/lttng/ustconsumerd64/command --consumerd-err-sock /var/run/lttng/ustconsumerd64/error

as we see, in that state, we have 2 consumers running.

#1

Updated by David Goulet about 8 years ago

  • Status changed from New to Feedback
  • Priority changed from Low to Normal

This seems to be fixed after the latest consumer fixes. On a critical session daemon exit, the consumer dies (which is the correct behaviour).

Can you confirm that this is indeed fixed?

#2

Updated by Mathieu Desnoyers about 8 years ago

  • Status changed from Feedback to Resolved

Yes, I confirm that the consumer daemon dies when the sessiond dies from a kill -9 now, both both kernel and userspace consumers. Tested with lttng-tools commit fc0c6bfbbe26b48832fad73c5a2ea9dd8c54c93b.

Also available in: Atom PDF