Project

General

Profile

Bug #1081

lttng-create behaviour does not match its command-line specification

Added by Daniel U. Thibault about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
12/14/2016
Due date:
% Done:

100%

Estimated time:

Description

The lttng-create (2.9) synopsis reads in part:

Live mode:

lttng [GENERAL OPTIONS] create --live[=DELAYUS] [--shm-path=PATH]
      [--set-url=URL | --ctrl-url=URL --data-url=URL] [SESSION]

Which means this should be legal:

lttng create --live testsession

This is what we actually get:

$ lttng create --live testsession
Error: Wrong value in --live parameter: testsession
Error: Command error

Either the code of lttng-create should be changed to correctly process its command line, or its man pages need to be adjusted.

#1

Updated by Daniel U. Thibault about 3 years ago

Note that this also means the example currently given in http://lttng.org/docs/v2.9/#doc-lttng-live fails on step 1.

#2

Updated by Jonathan Rajotte Julien about 3 years ago

  • Status changed from New to Confirmed
#4

Updated by Daniel U. Thibault about 3 years ago

This leaves the http://lttng.org/docs/v2.9/#doc-lttng-live page to be fixed, because it now gives illegal command lines for some of the examples ('lttng create --output=/tmp/some-directory my-session', 'lttng create --live my-session', 'lttng create --snapshot my-session').

#5

Updated by Jonathan Rajotte Julien about 3 years ago

Those changes are conditional to [1] acceptance.

The pull request for lttng-doc [2] is the minimum functional change. Only "--live session_name" order poses an immediate problem. Changes of arguments order for other create command will be changed depending on the result of [1].

Cheers

[1] https://lists.lttng.org/pipermail/lttng-dev/2017-January/026855.html
[2] https://github.com/lttng/lttng-docs/pull/19

#6

Updated by Jonathan Rajotte Julien about 3 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100
#7

Updated by Daniel U. Thibault about 3 years ago

Don't forget to fix http://lttng.org/docs/v2.9/#doc-lttng-live so it shows the new syntax.

Also available in: Atom PDF