Project

General

Profile

Actions

Bug #11

closed

Python sometimes registers to sessiond as lttng-ust application

Added by Mathieu Desnoyers almost 10 years ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
02/09/2012
Due date:
% Done:

100%

Estimated time:

Description

(skipping reproduction details because already fixed)

Closed by:

commit 476037d9a24fdd5e339e3565743aadb9cb8a0a96
Author: Mathieu Desnoyers <>
Date: Wed Feb 8 17:44:19 2012 -0500

Rename liblttng-ust-libc to liblttng-ust-libc-wrapper
What a beautiful piece of code we can find in python:
/usr/lib/python2.6/ctypes/util.py:
def _findLib_gcc(name):
expr = r'[^\(\)\s]*lib%s\.[^\(\)\s]*' % re.escape(name)
Basically, this match any library having "libc.so" in its name. It
should be reported to python developers as a bug, but let's not be the
first to trigger the issue in the wild.
Signed-off-by: Mathieu Desnoyers &lt;&gt;

No data to display

Actions

Also available in: Atom PDF