Project

General

Profile

Bug #1120

g_ptr_array_insert() requires glib2 >= 2.40

Added by Michael Jeanson over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
06/13/2017
Due date:
% Done:

100%

Estimated time:

Description

In 'plugins/ctf/fs-src/fs.c' we use 'g_ptr_array_insert()' which requires a glib2 version of at least 2.40, as documented here :

https://developer.gnome.org/glib/stable/glib-Pointer-Arrays.html#g-ptr-array-insert

Our current target is glib2 >= 2.22, should we bump this requirement or replace g_ptr_array_insert?

#1

Updated by Jérémie Galarneau over 2 years ago

  • Status changed from New to In Progress

Thanks for reporting, I'll make the change so we remain compatible with glib 2.22.

#2

Updated by Michael Jeanson over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF