Project

General

Profile

Actions

Bug #1237

closed

Built-in plugins are not relinked to the application after a modification

Added by Philippe Proulx over 2 years ago. Updated 3 months ago.

Status:
Resolved
Priority:
Low
Category:
Build system
Target version:
Start date:
02/17/2020
Due date:
% Done:

100%

Estimated time:

Description

The build system seems to be unaware that cli/babeltrace depends on the plugins. This is probably due to the (ab)use of LDFLAGS (see Makefile.am).

Actions #1

Updated by Jonathan Rajotte Julien over 2 years ago

  • Status changed from New to Feedback

Follow-up:

Simon Marchi wrote:

Is this only relevant when building with --enable-built-in-plugins? If plugins are external shared objects, then I guess cli/babeltrace is not linked against them, they are dlopened? And therefore, it's only at runtime that we will discover if a plugin is missing some symbol.

So I assume it's only when using built-in plugins, if you modify a plugin, then cli/babeltrace must be rebuilt to integrate the newly built plugin?

Jérémie Galarneau wrote:

Yes, this is for static builds (--enable-built-in-plugins). babeltrace.exe must be relinked when a plug-in is modified.

Actions #2

Updated by Jonathan Rajotte Julien over 2 years ago

Migrated from internal bug tracker.

Actions #3

Updated by Michael Jeanson 4 months ago

  • Status changed from Feedback to In Progress
  • Assignee set to Michael Jeanson
Actions #5

Updated by Michael Jeanson 3 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF