Project

General

Profile

Actions

Bug #1270

open

testsuite should use babeltrace2 binary if found

Added by Mathieu Desnoyers over 1 year ago. Updated 9 months ago.

Status:
In Progress
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
05/28/2020
Due date:
% Done:

0%

Estimated time:

Description

On a fresh system install, installing all lttng projects (master branches) and babeltrace (master branch) yield to lttng-tools make check failure because it is hardwired to use the "babeltrace" binary. However, babeltrace master branch now installs the "babeltrace2" binary.

One way to fix this would be to use the "babeltrace2" binary if found, else fallback on the "babeltrace" binary.

Actions #1

Updated by Jonathan Rajotte Julien over 1 year ago

  • Status changed from New to Confirmed

https://review.lttng.org/c/lttng-tools/+/3121

Not sure why I did not finish this. But I guess this is a start. There is a good probabilty that I was not fan of using a .in substitution file.

Actions #2

Updated by Mathieu Desnoyers over 1 year ago

I'm working on a fix for all use of the babeltrace binary.

There will be a single test which uses the babeltrace Python API which will require more care, because the API is changed: ./regression/kernel/validate_select_poll_epoll.py.

I will open a separate ticket for it.

Actions #3

Updated by Jonathan Rajotte Julien 9 months ago

  • Status changed from Confirmed to Resolved
Actions #4

Updated by Jérémie Galarneau 9 months ago

  • Status changed from Resolved to In Progress

I think this isn't resolved?
The patch has unaddressed comments.

https://review.lttng.org/c/lttng-tools/+/3121

Actions #5

Updated by Jonathan Rajotte Julien 9 months ago

I confused it with the "view" work that was done.

Thanks

Actions

Also available in: Atom PDF