Project

General

Profile

Actions

Bug #1343

open

Notifications tests hangs during OE/yocto.

Added by Jonathan Rajotte Julien 7 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
12/14/2021
Due date:
% Done:

0%

Estimated time:

Description

From Richard Purdie:

I noticed that the lttng-tools crash in relayd we previously talked about had a
fix in the repo and your bug was closed. Knowing that one is tracked down is
good news. I backported the fix as we've been seeing a lot of lttng-tools hangs
recently, it is back to failing nearly every build. You can see what I mean
here:

https://bugzilla.yoctoproject.org/show_bug.cgi?id=14263

Unfortunately even after the backport of the fix, it broke in our test build
which made me look further at where it was hanging. This is my result after
analysing a few of the most recent hangs:

https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/2826/steps/12/logs/stdio
qemux86-64-ptest
tools/notification/test_notification_kernel_instrumentation

https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/2850/steps/12/logs/stdio
qemux86-64-ptest debian11-ty-1
tools/notification/test_notification_kernel_capture

https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/2847/steps/12/logs/stdio
qemux86-64-ptest centos8-ty-1
tools/notification/test_notification_ust_capture

https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/2900/steps/12/logs/stdio
qemux86-64-ptest ubuntu2004-ty-2
tools/notification/test_notification_kernel_capture

https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/2903/steps/12/logs/stdio
qemux86-64-ptest fedora33-ty-1
tools/notification/test_notification_kernel_error

https://autobuilder.yoctoproject.org/typhoon/#/builders/81/builds/2905/steps/12/logs/stdio
qemux86-64-ptest ubuntu1804-ty-3
tools/notification/test_notification_ust_buffer_usage

https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/2648/steps/12/logs/stdio
ubuntu1804-arm-1
tools/notification/test_notification_kernel_userspace_probe

which tells us that it isn't arm or x86 specific, isn't isolated to a specific
host distro and seems to be in the tools/notification tests.

Is there any known issue there we should backport any fixes for?

Cheers,

Richard
<pre>

No data to display

Actions

Also available in: Atom PDF