Project

General

Profile

Bug #145

make check in lttng-tools fails sometimes

Added by Julien Desfossez about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
03/03/2012
Due date:
% Done:

0%

Estimated time:

Description

lttng-tools fc0c6bfbbe26b48832fad73c5a2ea9dd8c54c93b
lttng-ust bf1175c265545d44e4a898e0bc520d366cd7882a

Some segfaults, but result are still "OK".
Also, we have a "FAILED", but make check still returns 0.

-----------------------------------
UST tracer - Generate 100 events
-------------------------------------
Creating lttng session ust-nevents in /tmp/tmp.GZK3fgfGol OK
Enabling lttng event ust_gen_nevents:tptest for session ust-nevents OK
Start lttng tracing for session ust-nevents OK
./ust-nevents/run: line 45: 16911 Segmentation fault ./$CURDIR/gen-nevents $NR_ITER
Stop lttng tracing for session ust-nevents OK
Destroy lttng session ust-nevents OK
Looking for 100 ust_gen_nevents:tptest in /tmp/tmp.GZK3fgfGol 0 found in trace FAILED

-------------------------------------
UST tracer - Generate 100 process
---------------------------------------
Validating registered apps: OK
Creating lttng session ust-nprocesses in /tmp/tmp.4Rmad9zMyC OK
Enabling lttng event ust_gen_event:tptest for session ust-nprocesses ./ust-nprocesses//../utils.sh: line 96: 17141 Segmentation fault ./$CURDIR/$TEST_BIN_NAME 1000 > /dev/null 2>&1
OK
Start lttng tracing for session ust-nprocesses OK
Sleeping 5 seconds for tracing to start everywhere
Stop lttng tracing for session ust-nprocesses OK
Destroy lttng session ust-nprocesses OK
Killing all spawned applications...OK

[134472.861247] lt-lttng-sessio26426: segfault at 8 ip 000000000040e28f sp 00002b41c64f1980 error 4 in lt-lttng-sessiond[400000+29000]
[134676.598759] gen-nevents16911: segfault at 0 ip 00002b9a97fb1f76 sp 00007fff6e5785d8 error 4 in libc-2.13.so[2b9a97e97000+17d000]
[134676.826947] gen-events-time17156: segfault at 0 ip 00002b9dcbf32f7a sp 00002b9dcc9bcd68 error 4 in libc-2.13.so[2b9dcbe18000+17d000]

Rexecuting the make check without changing anything works perfectly.

#1

Updated by Julien Desfossez about 8 years ago

Sometimes I also have this error (I always run make check as user) :

--------------------------------------------------
Kernel tracer - Testing lttng client (liblttngctl)
--------------------------------------------------

Testing tracing kernel events:
-----------
Creating tracing session (/tmp/tmp.TJvggS7NCF): error creating the session : Ended with errors
kernel_event_basic: lttng/kernel_event_basic.c:182: main: Assertion `handle != ((void *)0)' failed.
./lttng/run-kernel-tests.sh: line 14: 31858 Aborted ./$bin $tmpdir
FAIL

Killing session daemon... FAILED

#2

Updated by David Goulet about 8 years ago

  • Status changed from New to Feedback

Having that much segfaults indicate that you have too old version of UST on your system and the binaries are not loving that!

Please make sure you have either git head or rc1 installed for the complete tool chain and no already running session daemon during the test. If the segfaults continues, we might have a bigger problem with something on your system.

#3

Updated by Julien Desfossez about 8 years ago

I cannot reproduce it anymore, you can close it.

#4

Updated by Yannick Brosseau about 8 years ago

  • Status changed from Feedback to Resolved

Cannot reproduce

Also available in: Atom PDF