Project

General

Profile

Bug #197

format null pointer error when trying to remove a trace

Added by Anonymous over 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
Start date:
03/27/2012
Due date:
% Done:

100%

Estimated time:

Description

In file babeltrace/lib/context.c in function bt_context_remove_trace(struct bt_context*, int), when calling the

handle->format->close_trace(...),

it doesn't work because format is null since the call to

g_hash_table_remove(...)

#1

Updated by Julien Desfossez about 8 years ago

  • Status changed from New to Feedback
  • Assignee set to Julien Desfossez
  • Target version set to Babeltrace 1.0

Hi,

I don't see the problem here, it seems to work and I don't get any error with a simple test (open a trace, read it and remove it).
Can you detail the error you receive and the steps to reproduce ?

Thanks,

Julien

#2

Updated by Anonymous about 8 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF