Project

General

Profile

Bug #209

libbabeltrace does not complains if it cannot correlate two traces

Added by Yannick Brosseau about 8 years ago. Updated almost 8 years ago.

Status:
Invalid
Priority:
Normal
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

We have two different traces. When we open them with babeltrace, it
complains that it cannot correlate the traces timestamps and stop.

When we open them with libbabeltrace, they open without warnings but the
timestamps are erroneous.

#1

Updated by Julien Desfossez about 8 years ago

  • Status changed from New to Feedback
  • Assignee set to Julien Desfossez
  • Target version set to Babeltrace 1.0

I don't see the problem.

With the API adding two traces with a different clocks, I get the following message and the return code is negative as expected :
[error] No clocks can be correlated and multiple traces are added to the collection. If you are certain those traces can be correlated, try using "--clock-force-correlate".
[error] Opening the trace

Can you provide a way to reproduce the problem ?

Thanks,

Julien

#2

Updated by Yannick Brosseau almost 8 years ago

  • Status changed from Feedback to Invalid

I cannot reproduce it.

Also available in: Atom PDF