Project

General

Profile

Bug #258

In struct lttng_event, enabled gets set to a negative value

Added by Danny Serres about 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
06/07/2012
Due date:
% Done:

100%

Estimated time:

Description

lttng_list_tracepoints sets the content of a struct lttng_event** and doing so,since it does not apply, sets enabled=-1 in the structures.

uint32_t enabled should then be changed to a int32_t type.

#1

Updated by Yannick Brosseau about 8 years ago

  • Project changed from LTTng to LTTng-tools
#2

Updated by David Goulet about 8 years ago

  • Status changed from New to Confirmed
  • Assignee set to David Goulet
  • Target version set to 2.0.x stable

To merge

#3

Updated by David Goulet almost 8 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF