Project

General

Profile

Bug #293

API problem with bt_iter_set_pos

Added by Julien Desfossez almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
Start date:
07/04/2012
Due date:
% Done:

100%

Estimated time:

Description

Reported by Francis Deslauriers

program to trigger the bug :
git clone -b seektest git://git.dorsal.polymtl.ca/~fdeslauriers/babeltrace-api-test/.git

trace to trigger the bug :
wget http://www.dorsal.polymtl.ca/~fdeslauriers/trace_problematique.tar.gz

The test program iterates over the trace, it does the following in loop until there are no more events :
- save the position of the iterator
- read 2 events
- restore the position of the iterator
- read 1 event

So each event is saved and restored once.

At the end of this trace, it seems that we cannot get past the last event of CPU 7 (103572.478927352) even though there are other events in other streams.

For the other streams, when a stream has no more events, its "current" timestamp is the timestamp of destruction of the buffer which is far in the future.

But in this particular scenario, it seems that we never get past the current event. When we save the position, we record the timestamp of this event, so everytime we restore to the next event, this one is also restored and since it has the smallest timestamp and it gets processed, endlessly...


Related issues

Related to Babeltrace - Bug #296: libbabeltrace segfault in mmap_align_addrResolved07/09/2012

Actions
#1

Updated by Yannick Brosseau over 7 years ago

If you need another trace, I have another one that segfaults.

#2

Updated by Julien Desfossez over 7 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF