Project

General

Profile

Bug #306

kernel modules hitting might_sleep()

Added by Steve Rotolo almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
High
Target version:
-
Start date:
07/16/2012
Due date:
% Done:

0%

Estimated time:

Description

I am testing out LTTng kernel modules 2.0.4 on a 3.3.8 kernel and I am seeing LOTs of "BUG: sleeping function called from invalid context" errors on the console. I have attached 2 files showing various stack traces leading to might_sleep(); one is while tracing all "tracepoints", the other is while tracing all "syscalls".

I have also attached my kernel config.


Files

BUG1.txt (1.19 KB) BUG1.txt might_sleep during tracepoints Steve Rotolo, 07/16/2012 03:48 PM
BUG2.txt (6.59 KB) BUG2.txt might_sleep during syscalls Steve Rotolo, 07/16/2012 03:48 PM
config (123 KB) config kernel .config Steve Rotolo, 07/16/2012 03:48 PM
#1

Updated by Mathieu Desnoyers almost 8 years ago

  • Status changed from New to Confirmed
  • Assignee set to Mathieu Desnoyers
  • Priority changed from Normal to High
#2

Updated by Mathieu Desnoyers almost 8 years ago

  • Status changed from Confirmed to Resolved

Fixed by commits:

master branch:

commit 0658bdda04bf2b00a1a4a3fcb92bfd805d30fde9
Author: Mathieu Desnoyers <>
Date: Wed Aug 22 17:09:20 2012 -0400

Fix: statedump: disable vm maps enumeration
We need the tasklist lock to correctly dump these, which is unavailable
to modules. Disable this feature for now.
Signed-off-by: Mathieu Desnoyers &lt;&gt;

commit 7b8ea3a503536c9d00f8bb14958a150cbf7370c0
Author: Mathieu Desnoyers <>
Date: Wed Aug 22 16:30:20 2012 -0400

Fix: ensure userspace accesses are done with _inatomic
Otherwise, triggers scheduling while atomic (might_sleep()) warnings,
since we call those from a tracepoint probe (with preemption disabled).
Signed-off-by: Mathieu Desnoyers &lt;&gt;

stable-2.0 branch:

commit 67ee762a41793b34750f655737e5fbe7f5be1dc5
Author: Mathieu Desnoyers <>
Date: Wed Aug 22 17:09:20 2012 -0400

Fix: statedump: disable vm maps enumeration
We need the tasklist lock to correctly dump these, which is unavailable
to modules. Disable this feature for now.
Signed-off-by: Mathieu Desnoyers &lt;&gt;

commit b8ec0e19b7c494de10aa3a008d6733ee6d5c6fc7
Author: Mathieu Desnoyers <>
Date: Wed Aug 22 16:30:20 2012 -0400

Fix: ensure userspace accesses are done with _inatomic
Otherwise, triggers scheduling while atomic (might_sleep()) warnings,
since we call those from a tracepoint probe (with preemption disabled).
Signed-off-by: Mathieu Desnoyers &lt;&gt;

Also available in: Atom PDF