Project

General

Profile

Bug #339

Subbuffer size of < 4096 are accepted but unable to use the channel afterwards

Added by David Goulet almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Target version:
Start date:
09/17/2012
Due date:
% Done:

0%

Estimated time:

Description

Using the code attached below to create the channel:

$ gcc -llttng-ctl lttng.c -o test-lttng

and

$ ./test-lttng
$ lttng enable-event -a -u -c mychan -s mysession

Outputs:
Error: Events: Enable UST event failed (channel mychan, session mysession)

The error is reported when enabling an event and not the channel itself.

Thanks!


Files

lttng.c (961 Bytes) lttng.c David Goulet, 09/17/2012 04:08 PM

Related issues

Related to LTTng-tools - Bug #235: lttng_enable_channel with too little subbuffers size returns an error that isn't explicitResolved05/08/2012

Actions
#1

Updated by Yannick Brosseau almost 8 years ago

  • Assignee set to Mathieu Desnoyers
#2

Updated by Yannick Brosseau almost 8 years ago

  • Target version set to 2.1 stable
#3

Updated by Mathieu Desnoyers almost 8 years ago

  • Status changed from New to Feedback

I tried 2 scenarios:

1) no app running, running the test program, and enable.

No error.

2) hello running in background (in a 3000 sec. wait), running the test program fails with:

Enable channel: UST create channel failed

(and there seems to be a missing \n after the error message)

So I cannot reproduce your problem. Maybe you ran the test prog, launched an UST app, and then got the error at enable event ?

Please detail your test case, including whether an UST app is running or not, so I can reproduce.

Thanks,

Mathieu

#4

Updated by Mathieu Desnoyers over 7 years ago

  • Status changed from Feedback to Resolved

For applications not started when issuing create channel, fixed by lttng-tools commit:

commit 95e047ff8e01767e2e18b892f7a1ba9bf28abcbe
Author: David Goulet <>
Date: Thu Dec 13 17:51:45 2012 -0500

Fix: RCU unlock out of error path
On channel error, RCU was not unlocking the read side. Furthermore,
remove a check for a NULL session that was also not going through an RCU
unlock. Change it to an assert.
This also adds a channel subbuf size check when enabling a channel.
Signed-off-by: David Goulet &lt;&gt;

For apps already started, it was already working fine.

Also available in: Atom PDF