Project

General

Profile

Actions

Bug #344

closed

--filter ' intfield > intfield2 ' is not supported

Added by Tan le tran almost 12 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
High
Assignee:
Christian Babeux
Target version:
Start date:
09/18/2012
Due date:
% Done:

100%

Estimated time:

Description

Commit used: ============
userspace : (Thu Sep 6 ) a5a9f42 Ensure that read-side functions meet 10-line LGPL criterion
lttng-ust : (Tue Sep 18) 5d3bc5e Fix: get_wait_shm() ust mutex deadlock (add 2 missing exit calls)
lttng-tools:(Tue Sep 18) 4adabd6 Fix: Remove LPOLLNVAL from consumer metadata revents
babeltrace: (Thu Sep 13) f546472 Fix: Documentation cleanup

Scenario: =========
1)_ Run the instrumented app (in this case, the demo coming with lttng-ust is used)
demo-trace 50 &
2)_ lttng create $SESSION_NAME -o /cluster/temp/sessiondir/$SESSION_NAME
3)_ lttng enable-event ust_tests_demo2:loop -u --filter ' intfield > intfield2 '
get:
libust[24571/24572]: Error: unknown bytecode op 0
(in bytecode_validate_overflow() at lttng-filter-validator.c:184)
libust[24571/24572]: Error: filter bytecode overflow
(in lttng_filter_validate_bytecode() at lttng-filter-validator.c:1103)

Expected Behavior: ==================
Since the tracepoint "ust_tests_demo2:loop" of demo application is instrumented with fields
intfield and intfield2, the user should be able to use them in the filter expression to
compare field vs field .


Files

log.txt (51.1 KB) log.txt Terminal log with "sessiond -vvv" Tan le tran, 09/18/2012 05:25 PM
Actions #1

Updated by Mathieu Desnoyers almost 12 years ago

  • Project changed from LTTng-UST to LTTng-tools
  • Status changed from New to Confirmed
  • Priority changed from Normal to High

[debug bytecode] Linking
[debug bytecode] Apply reloc: 0 intfield
[debug bytecode] Apply reloc: 3 intfield2
[debug bytecode] Validating op LOAD_FIELD_REF_S64 (62)
[debug bytecode] Validate load field ref offset 0 type s64
[debug bytecode] Validating op LOAD_FIELD_REF_S64 (62)
[debug bytecode] Validate load field ref offset 8 type s64
libust[7885/7885]: Error: unknown bytecode op 0
(in bytecode_validate_overflow() at lttng-filter-validator.c:184)
[debug bytecode] [lttng filter] warning: cannot link event bytecode

it looks like tools is sending an unknown (0) bytecode in this case.

Actions #2

Updated by David Goulet almost 12 years ago

  • Assignee set to Christian Babeux
  • Target version set to 2.1 stable
Actions #3

Updated by Mathieu Desnoyers over 11 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF