Project

General

Profile

Bug #352

metadata partly missing with large subbuffers and stress-test

Added by Mathieu Desnoyers almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Target version:
Start date:
09/25/2012
Due date:
% Done:

0%

Estimated time:

Description

08:19 < Compudj> dgoulet, cbab: fyi, with lttng-tools master, I just ran into
an issue with incomplete metadata
08:20 < Compudj> dgoulet, cbab: I used a channel config of 2 subbuffers/512MB
per subbuffer, tracing a ping flood on localhost, stopping
tracing after I notice that I have 2 buffers written to disk
by the consumer
08:20 < Compudj> dgoulet, cbab: with kernel tracing
08:20 < Compudj> dgoulet, cbab: this is probably related to the problems you
are looking for. so it's another way to reproduce it I guess.
08:21 < Compudj> dgoulet, cbab: or it could very well be a different issue.
08:22 < Compudj> dgoulet, cbab: and the lttng-modules tracer did not complain
about any timeout, nor did the start operation
08:22 < Compudj> dgoulet, cbab: fyi, the ping flood was running before I
started tracing

#1

Updated by David Goulet almost 8 years ago

  • Status changed from New to Confirmed
  • Target version set to 2.1 stable

The high throughput test using "tc" to limit the bandwidth was merged upstream today and brings two new issues that can be related to this bug. See the tests/tools/streaming/high_throughput_limits file for more information (look for #FIXME comments).

I'll flag this bug as Confirmed and targeting 2.1-stable since those problems can be reproduced easily.

#2

Updated by David Goulet almost 8 years ago

With 2.1.0-rc5, the high_throughput_limits test now passes but there is still an issue with the the bandwidth limit on the control socket. It might be the script since the trace is readable but the number of events is not right...

#3

Updated by David Goulet almost 8 years ago

  • Status changed from Confirmed to Feedback

Hmmm, I can't enable a channel of 512MB buffer size. What's the command?

  1. lttng enable-channel -k --subbuf-size 536870912 --num-subbuf 2 chan1

I've tested a ping flood with the default setting and it's working fine here.

#4

Updated by David Goulet over 7 years ago

  • Status changed from Feedback to Resolved

This is fixed on my side. Can't reproduce the issue with a ping flood and large subbuffers.

Also available in: Atom PDF