Project

General

Profile

Actions

Bug #408

closed

disable-event -u -a disables _all_ events (not just wildcards)

Added by Mathieu Desnoyers almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Target version:
Start date:
12/04/2012
Due date:
% Done:

0%

Estimated time:

Description

Wondering what should happen here:

lttng create
lttng enable-event -u 'ust*' --filter 'intfield==42'
lttng enable-event -u -a
lttng disable-event -u -a
lttng start

./hello
lttng stop; lttng view

Expected: 1 event with intfield == 42, result: no event at all.

However, if we use the '*' wildcard instead of -a, we get the expected result. I would have expected -a to behave in the same way as '*', but it's not the case for disable. Any reason for that ?

Thanks,

Mathieu

Actions #1

Updated by David Goulet almost 9 years ago

Nope not suppose to happen.

It's working for me so maybe a weird version of UST or ... ?

I can confirm that ust* gets disabled:

DEBUG1: UST app disabling event ust* for all apps in channel channel0 for session id 0 [in ust_app_disable_event_glb() at ust-app.c:1887]
DEBUG2: Event UST ust* disabled in channel channel0 [in event_ust_disable_tracepoint() at event.c:560]

Actions #2

Updated by David Goulet almost 9 years ago

  • Status changed from New to Confirmed
  • Assignee deleted (David Goulet)
  • Priority changed from Normal to Low
  • Target version set to 2.2

This is indeed a difference between enable and disable.

For 2.x, we can't really change the behavior of the options nor change it since we'll be facing an "API" breakage on the UI front. I'll flag this issue for 2.2 and see what we can do in the future about it.

Actions #3

Updated by Yannick Brosseau almost 9 years ago

As a user I would expect that the disable -u -a disable ALL events even the ones added with wildcard...

Actions #4

Updated by David Goulet almost 9 years ago

It does yes.

:

Issue #408 has been updated by Yannick Brosseau.

As a user I would expect that the disable u -a disable ALL events even the ones added with wildcard...
---------------------------------------

Bug #408: disable-event -u -a disables all events (not just wildcards)
https://bugs.lttng.org/issues/408#change-1023

Author: Mathieu Desnoyers
Status: Confirmed
Priority: Low
Assignee:
Category:
Target version: 2.2

Wondering what should happen here:

lttng create
lttng enable-event -u 'ust*' --filter 'intfield==42'
lttng enable-event -u -a
lttng disable-event -u -a
lttng start

./hello
lttng stop; lttng view

Expected: 1 event with intfield == 42, result: no event at all.

However, if we use the '*' wildcard instead of -a, we get the expected result. I would have expected -a to behave in the same way as '*', but it's not the case for disable. Any reason for that ?

Thanks,

Mathieu

Actions #5

Updated by Yannick Brosseau almost 9 years ago

Ok, reading the issue, I thought you wanted to -u -a to not disable the
event added with the -u "ust*"

Actions #6

Updated by David Goulet almost 9 years ago

  • Status changed from Confirmed to Resolved

This has been documented in the man page.

Closing it.

Actions

Also available in: Atom PDF