Project

General

Profile

Actions

Bug #444

closed

lttng enable-event misbehaves when multiple event types are specified

Added by Daniel U. Thibault over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
02/14/2013
Due date:
% Done:

100%

Estimated time:

Description

Inspection of the enable_events.c code reveals that if the user specifies multiple event types as command options, all but the last one are ignored. A user could specify a list of event names followed by a list of event type options, expecting one-on-one correspondence between them. For example:

lttng enable-event eventone,eventtwo -k --probe probesymbol --function functionsymbol

is equivalent to:
lttng enable-event eventone -k --probe probesymbol
lttng enable-event eventtwo -k --function functionsymbol

Currently the first command actually resolves to:
lttng enable-event eventone -k --function functionsymbol
lttng enable-event eventtwo -k --function functionsymbol

Because allowing multiple event types as well as multiple event names is fraught with difficulties (e.g. what if the two lists are of different lengths?), it should probably be discouraged. Specification of multiple event types in a single enable-event command should be an error condition.

The same observation holds when multiple event types are combined with the --all command option (i.e. 'lttng enable-event -k --all --syscall --tracepoint' is treated the same as 'lttng enable-event -k --all --tracepoint').

Actions #1

Updated by Christian Babeux over 8 years ago

  • Status changed from New to Confirmed
  • Priority changed from Normal to Low
Actions #2

Updated by David Goulet over 8 years ago

  • Priority changed from Low to Normal
  • Target version set to 2.2

This is a very good point.

I'm tagging this one for 2.2 thus having to make a decision before the release.

Actions #3

Updated by David Goulet over 8 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF