Project

General

Profile

Bug #579

Trying to apply a context-related filter quickly after adding the same parameters to the context fails

Added by Anonymous almost 7 years ago. Updated almost 7 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
06/27/2013
Due date:
% Done:

0%

Estimated time:

Description

Reproduction sequence:

lttng-sessiond --no-kernel -v --verbose-consumer
lttng create samba -o /local/traces/lttng/20130625114835
lttng enable-channel channel0 -u \
                        --tracefile-size ${LTTNG_MAX_TRACE_FILE_SIZE} \
                        --tracefile-count ${LTTNG_MAX_FILES_PER_CORE} \
                        --buffers-uid \
                        --switch-timer 1000000 \
                        --num-subbuf 16 \
                        --subbuf-size 262144
lttng add-context -u -t procname -s samba -c channel0
lttng enable-event -u -a --filter '$ctx.procname == "smbd" || $ctx.procname == "winbindd"'

All commands succeed except the last one, which produces this output:

error syntax error
Parse error
Error: Invalid filter bytecode

To overcome the situation after the script has failed, I simply ran:

lttng disable-channel -u -a

And then issued the same enable-event again, which (at that point in time) succeeds.


Files

sessiond.log.bz2 (22.9 KB) sessiond.log.bz2 Anonymous, 07/10/2013 01:00 AM
#1

Updated by David Goulet almost 7 years ago

  • Assignee deleted (David Goulet)

I'm unable to reproduce that on master HEAD.

Can you provide the lttng-sessiond logs (-vvv).

#2

Updated by Anonymous almost 7 years ago

The issue as described above doesn't happen anymore. However, trying to add vpid or vtid causes the output directory to be empty, i.e. directory created but no files appear in it. The sessiond output includes a line like this:

DEBUG3 [1291/1296]: Creating channel to ustctl with attr: [overwrite: 0, subbuf_size: 262144, num_subbuf: 16, switch_timer_interval: 1000000, read_timer_inter
val: 0, output: 0, type: 0 (in create_ust_channel() at ust-consumer.c:348)
libringbuffer[1291/1296]: Error: zero_file: No space left on device (in _shm_object_table_alloc_shm() at shm.c:173)
DEBUG1 [1291/1296]: UST consumer cleaning stream list (in destroy_channel() at ust-consumer.c:60)

#3

Updated by Anonymous almost 7 years ago

Does that mean I need to confirm this as "can't reproduce" and open a different bug report?

#4

Updated by Anonymous almost 7 years ago

Something I've tried made this work - I reduced the size of the subbuffers from 256KB to 64KB.
I've also tracked down 2 systems of ours that exhibit different behvior - one works with 256KB and one doesn't. Here are the differences:
1) Number of CPU cores.
2) Total RAM size.

In the system that works with 256KB subbuffers, the RAM is 24GB, and it has a 6-core CPU with HT (presenting itself as a 12-core).

The other system has a dual CPU configuration - 2x6 cores, each presenting 12 cores, for a total of 24 cores. The other system's RAM size is 96GB.

#5

Updated by Mathieu Desnoyers almost 7 years ago

  • Status changed from New to Resolved

I'm marking the original bug as invalid, since it cannot be reproduced by neither you nor us.

For the second issue you are experiencing, please open a new bug.

Thanks,

Mathieu

#6

Updated by Mathieu Desnoyers almost 7 years ago

  • Status changed from Resolved to Invalid

Also available in: Atom PDF