Project

General

Profile

Actions

Bug #605

closed

lttng enable-channel -u --type splice hangs the root user-space consumer

Added by Daniel U. Thibault about 8 years ago. Updated about 8 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Target version:
Start date:
07/25/2013
Due date:
% Done:

0%

Estimated time:

Description

(User belongs to tracing group, root lttng-sessiond is running)

$ lttng create t
Session t created.
Traces will be written in /home/daniel/lttng-traces/t-20130725-161359
$ lttng enable-channel ch0 -u --output splice
Error: Channel ch0: Operation not supported (session t)
Warning: Some command(s) went wrong
$ lttng enable-channel ch1 -k --output mmap
Error: Channel ch1: No kernel consumer detected (session t)
Warning: Some command(s) went wrong
$ lttng destroy t
Session t destroyed
$ sudo service lttng-sessiond restart

The lttng-sessiond service had to be restarted as the root user-space lttng-consumerd daemon was hung (as shown by the system monitor). You can also tell because lttng enable-channel ch1 -k --output mmap works fine if not preceded by lttng enable-channel ch0 -u --output splice.

Actions #1

Updated by David Goulet about 8 years ago

  • Project changed from LTTng to LTTng-tools
  • Status changed from New to Confirmed
  • Target version changed from 2.3 to 2.2
Actions #2

Updated by Mathieu Desnoyers about 8 years ago

  • Status changed from Confirmed to Feedback

Cannot reproduce.

Can you try against LTTng stable-2.2 up to date branches, and also against master branches (for lttng-ust, lttng-modules, and lttng-tools) ?

Please detail which commits (for each project) you test against in the bug report.

Thanks,

Mathieu

Actions #3

Updated by David Goulet about 8 years ago

We will probably release 2.3-stable this week so if this is unanswered until then, I'll close it and flagg it Invalid.

Thanks!

Actions #4

Updated by David Goulet about 8 years ago

  • Status changed from Feedback to Invalid

Please make sure to update your branch to the git HEAD. If it can be reproduce, please provide the commit ID of lttng-tools and lttng-ust.

I'll flag this one invalid for now and we'll reopen it if any issues rise up! :)

Cheers!

Actions #5

Updated by Daniel U. Thibault about 8 years ago

With the current config:

lttng-modules-2.3.0-rc2-7 c126f57
lttng-tools-2.3.0-rc3-1 3e618c7
lttng-ust-2.3.0-rc2-1 07d2f70
userspace-rcu-0.7.4-210-(0.7.7-69) e53ab1e

This bug does not recur.

Actions

Also available in: Atom PDF