Project

General

Profile

Actions

Bug #629

closed

Cannot enable events after a stop command

Added by Yannick Brosseau over 8 years ago. Updated about 8 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
09/09/2013
Due date:
% Done:

0%

Estimated time:

Description

Using the latest release (2.3), I cannot enable events after I issue a start and stop commands.


Related issues 2 (1 open1 closed)

Related to LTTng-UST - Feature #742: Enable channel *after* tracing has startedInvalid02/26/2014

Actions
Related to LTTng-modules - Feature #743: Enable channel *after* tracing has startedNew02/26/2014

Actions
Actions #1

Updated by Yannick Brosseau over 8 years ago

See the command line output:

root@atwood:~# lttng create
Session auto-20130909-123758 created.
Traces will be written in /root/lttng-traces/auto-20130909-123758
root@atwood:~# lttng enable-event -u -a
All UST events are enabled in channel channel0
root@atwood:~# lttng start
Tracing started for session auto-20130909-123758
root@atwood:~# lttng stop
Waiting for data availability
Tracing stopped for session auto-20130909-123758
(reverse-i-search)`enabl': lttng ^Cable-event -u -a
root@atwood:~# lttng enable-event -k -a --syscall
Error: Events: Tracing already started (channel channel0, session auto-20130909-123758)
root@atwood:~# lttng start
Tracing started for session auto-20130909-123758
root@atwood:~# lttng stop
Waiting for data availability
Tracing stopped for session auto-20130909-123758
Actions #2

Updated by Yannick Brosseau over 8 years ago

output of the session daemon:
http://paste.debian.net/37508/

Actions #3

Updated by Yannick Brosseau over 8 years ago

  • Subject changed from Can enable events after a stop command to Cannot enable events after a stop command
Actions #4

Updated by David Goulet over 8 years ago

  • Status changed from New to Confirmed
  • Priority changed from High to Normal

So yes this is a limitation of the tracer (both kernel and ust). Once a session has started, you can't enable any more channel. In this case, there is no existing kernel channel after the stop thus doing "-a -k" fails because it tries to create "channel0".

You have to enable a channel prior to the start and then you'll be able to enable/disable whatever you like in it.

Now, what I'm realizing is that there is NO documentation of that limitation. So, what I propose is to rename that ticket so it becomes a documentation bug. I think we should document that in the tracer man page but also in lttng.1 since people will most likely encounter this issue with the lttng command line.

Thoughts?

Actions #5

Updated by David Goulet over 8 years ago

  • Status changed from Confirmed to Feedback
Actions #6

Updated by Yannick Brosseau over 8 years ago

I might be wrong, but I think it was possible to do this before?

Actions #7

Updated by Yannick Brosseau over 8 years ago

I strongly think we should get rid of this limitation, not just document it.

Actions #8

Updated by David Goulet over 8 years ago

It's possible but maybe changes in 2.1 or 2.2 changed that behavior.
There is now an explicit check done for that use case in the session
daemon in order to avoid to send the request to the tracer.

I can't be sure on before but for now it's certain you can't. No idea on
the specifics though. You'll have to ask Mathieu for that.

Actions #9

Updated by David Goulet over 8 years ago

Well, that's a tracer issue. Let's put Mathieu in the loop for that.

Actions #10

Updated by David Goulet about 8 years ago

  • Status changed from Feedback to Won't fix

Two feature requests related to this issue have been open for each tracer.

Actions

Also available in: Atom PDF