Project

General

Profile

Bug #636

[PPA] Enabling some kernel events fails with invalid ioctl with lttng 2.3 stable

Added by Francis Giraldeau almost 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Target version:
Start date:
09/18/2013
Due date:
% Done:

0%

Estimated time:

Description

When trying to enable a kernel event, the following error is obtained:

Client side:

$ lttng create 
Session auto-20130918-123048 created.
Traces will be written in /home/francis/lttng-traces/auto-20130918-123048
$ lttng enable-event -k mm_page_alloc
Error: Event mm_page_alloc: Enable kernel event failed (channel channel0, session auto-20130918-123048)
Warning: Some command(s) went wrong

On lttng-sessiond side:

PERROR [4059/4160]: create event ioctl: Invalid argument (in kernel_create_event() at kernel.c:205)

Installed with packages from stable Ubuntu PPA:

$ dpkg -l | grep lttng
ii  liblttng-ctl0:amd64   2.3.x+stable-0+bzr1839+pack7+201309141748~ubuntu13.04.1
ii  liblttng-ust-dev      2.3.x+stable-0+bzr1641+pack41+201309091817~ubuntu13.04.1
ii  liblttng-ust0:amd64   2.3.x+stable-0+bzr1641+pack41+201309091817~ubuntu13.04.1
ii  lttng-modules-dkms    2.3.x+stable-0+bzr537+pack15+201309162039~ubuntu13.04.1
ii  lttng-tools           2.3.x+stable-0+bzr1839+pack7+201309141748~ubuntu13.04.1

$ uname -a
Linux dyn37 3.8.0-30-generic #44-Ubuntu SMP Thu Aug 22 20:52:24 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

#1

Updated by Francis Giraldeau almost 7 years ago

I just installed a fresh install with Ubuntu 13.04 and ppa:lttng/ppa and I confirm this bug is reproducible.

The version 2.4-pre of ppa:lttng/daily is also affected by this bug.

#2

Updated by Francis Giraldeau almost 7 years ago

After verification, the module lttng-probe-kmem is not loaded. DKMS do not compile this module, even if the source file lttng-probe-kmem.c is present. This should be investigated.

#3

Updated by Anonymous almost 7 years ago

  • Subject changed from Enable kernel event failed with invalid ioctl with lttng 2.3 stable to [PPA] Enabling some kernel events fails with invalid ioctl with lttng 2.3 stable
  • Status changed from New to In Progress
  • Priority changed from Critical to High
  • Assignee set to Anonymous

Seems to be a packaging problem. The recipe used for the PPA was quite old, and new modules have been added since. I've pulled in the latest version from Debian Unstable for the PPA packages, which should (hopefully) build everything needed:

http://bazaar.launchpad.net/~lttng/lttng-modules/packaging-daily/revision/15
http://bazaar.launchpad.net/~lttng/lttng-modules/packaging-stable/revision/16

I'll retest once Launchpad finishes building those.

#4

Updated by Anonymous almost 7 years ago

  • Project changed from LTTng-tools to LTTng-modules
#5

Updated by Anonymous almost 7 years ago

  • Status changed from In Progress to Resolved

Stable and daily packages should now be fixed.

Using lttng-modules-dkms 2.4~pre-0+bzr541+pack17+201309191827~ubuntu13.04.1 from the daily PPA:

$ lttng enable-event -k mm_page_alloc
kernel event mm_page_alloc created in channel channel0

Took some time because I hit #637 on the way, but that shouldn't affect the PPA packages, since we only build for x86 and x86_64.

Thanks for testing and reporting this!

Also available in: Atom PDF