Project

General

Profile

Bug #660

lttng snapshot record fails to increment the snapshot sequence number

Added by Daniel U. Thibault over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
11/15/2013
Due date:
% Done:

0%

Estimated time:

Description

Using:
lttng-modules 2.3.0-1 78c8710
lttng-tools 2.3.0-1 c9dc128
lttng-ust 2.3.0-1 9f00ce3
userspace-rcu 0.8.0-1 ca617ca
on:
Ubuntu 12.04.3 LTS precise,
3.2.0-53-virtual kernel

$ sudo -H lttng create mySession --snapshot
Spawning a session daemon
Session mySession created.
Default snapshot output set to: /root/lttng-traces/mySession-20130925-101114
Snapshot mode set. Every channel enabled for that session will be set in overwrite mode and mmap output.
$ sudo -H lttng enable-event -a -k -syscall
All kernel system calls are enabled in channel channel0
$ sudo -H lttng start
Tracing started for session mySession
$ sudo -H lttng snapshot record
Snapshot recorded successfully for session mySession
$ sudo -H lttng snapshot record
Snapshot recorded successfully for session mySession

If the two snapshot record commands are issued within the same one-second window, I get just one snapshot in lttng-traces (e.g. mySession-20131115-102848/snapshot-1-20131115-103147-0). Presumably the second one overwrote the first. I am unable to get any snapshots with a ...-1 snapshot folder name.

#1

Updated by Mathieu Desnoyers over 6 years ago

  • Project changed from LTTng to LTTng-tools
  • Assignee set to David Goulet
#2

Updated by David Goulet over 6 years ago

  • Status changed from New to Resolved
  • Assignee deleted (David Goulet)
  • Target version changed from 2.4 to 2.3

I'm unable to reproduce that so considering the amount of time that bug has been opened, my guess is that it has been fixed.

Also available in: Atom PDF