Project

General

Profile

Bug #692

JUL: Make sure we receive already enabled events before sending the registration done to the Agent

Added by David Goulet over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
11/20/2013
Due date:
% Done:

100%

Estimated time:

Description

There is a race between the events being enabled by the session daemon and the Logger in the application starting to log data. That race basically miss the early events in the Java application because the Logger are being enabled.

To fix that, we must enable events before the registration is completed.

#1

Updated by Mathieu Desnoyers about 6 years ago

  • Project changed from LTTng-tools to LTTng-UST
#2

Updated by David Goulet about 6 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF