Project

General

Profile

Bug #698

babeltrace sometimes ignores changing metadata rendering hints

Added by Daniel U. Thibault over 6 years ago. Updated about 6 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/26/2013
Due date:
% Done:

0%

Estimated time:

Description

If I have an instrumented application that uses e.g. ctf_integer for some payload field, babeltrace will render that field using standard decimal notation. If another version of the application instead uses ctf_integer_hex, the data stored in the trace does not change but the metadata will hold a "hint" which will tell babeltrace to render the field in hexadecimal notation. So far so good.

The bug I've run into with LTTng 2.3.0 and babeltrace 1.1.1 occurs within a single tracing session: if I run the ctf_integer application and later run the ctf_integer_hex application (same tracepoint provider name and event name), babeltrace will not get the hexadecimal rendering hint for the later event records. Either the event's changing format isn't in the metadata or babeltrace fails to look it up when processing the trace (so this either an lttng bug or a babeltrace bug). I strongly suspect the latter because the metadata doubles in size when I run the changing ctf_ scenario, compared with running either app twice.


Related issues

Related to LTTng-tools - Bug #720: Disambiguating fully qualified event names, timestamp-sensitive metadataConfirmed01/16/2014

Actions
#1

Updated by Mathieu Desnoyers about 6 years ago

  • Status changed from New to Won't fix

lttng sessiond should have validated that the second event is refused.

Also available in: Atom PDF