Project

General

Profile

Bug #740

multiple sessiond in the system triggers bind error (unclear to user)

Added by Mathieu Desnoyers about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
02/25/2014
Due date:
% Done:

100%

Estimated time:

Description

When running a root and per-user session (or 2 per-user sessiond), the second instance started prints:

PERROR [32547/32653]: bind inet: Address already in use (in lttcomm_bind_inet_sock() at inet.c:109)

I understand that this is caused by the new JUL feature, and there is no elegant way around it: a port can only be bind by a single process in listen.

We should however provide a more meaningful error message to the user, telling them that it's only JUL which will not be active in this session daemon, and that it does not interfere with the rest of tracing.

#1

Updated by David Goulet about 6 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF