Project

General

Profile

Bug #745

base address dump triggers deadlocks

Added by Mathieu Desnoyers over 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Critical
Target version:
Start date:
02/27/2014
Due date:
% Done:

100%

Estimated time:

Description

It appears that the daemon() test case of lttng-tools deadlocks when base address is dumped.
(lttng-tools tests/regression/ust/daemon)

From preliminary analysis, it seems to be a hang in the child process, likely caused by use of the dynamic linker lock within a lttng-ust thread without protection of ust_lock().

We'll need to figure out a way to rework locking to make use of the dynamic linked safe wrt fork/clone/daemon. It's possible that we need to disable the base address feature for 2.4, as it is late in the rc cycle.

Also available in: Atom PDF