Project

General

Profile

Actions

Bug #75

closed

API Documentation for libbabeltrace

Added by Yannick Brosseau almost 10 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
Start date:
02/19/2012
Due date:
% Done:

100%

Estimated time:

Description

Documentation for the API is missing.

Actions #1

Updated by Julien Desfossez almost 10 years ago

  • Assignee set to Julien Desfossez
Actions #2

Updated by Julien Desfossez over 9 years ago

  • Status changed from New to Resolved

the API doc is OK, we actually need more a developper guide, closing this bug and creating a new one for that.

Actions #3

Updated by Yannick Brosseau over 9 years ago

  • Status changed from Resolved to Confirmed

Reopened, because the API doc miss some part:

bt_context_add_trace:
Some parameter are not documented (format, path)
Need more explanation on the stream_list

bt_iter_pos:
What is the format of the seek_time param

Actions #4

Updated by Yannick Brosseau over 9 years ago

document that bt_iter is an abstract class

Actions #5

Updated by Yannick Brosseau over 9 years ago

bt_ctf_iter_read_event doc is WRONG!

Actions #6

Updated by Anonymous over 9 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF