Project

General

Profile

Actions

Bug #775

closed

UST cannot register to any sessiond without HOME env variable

Added by Julien Desfossez over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
04/01/2014
Due date:
% Done:

0%

Estimated time:

Description

It seems that if the HOME environment variable is not present, an application instrumented with UST cannot register to the sessiond (as root and as user).

With LTTng 2.4 and UST 2.4 (stable release packages).
Here are the 3 lines that appear when starting the program :
libust[27940/27940]: Warning: HOME environment variable not set. Disabling LTTng-UST per-user tracing. (in setup_local_apps() at lttng-ust-comm.c:305)
libust[27940/27941]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)
libust[27940/27941]: Error: Error opening shm /lttng-ust-wait-5 (in get_wait_shm() at lttng-ust-comm.c:886)

This issue was detected with QEMU compiled with UST and libvirt starting the VMs.
When starting qemu manually everything is fine, but when libvirt starts it, it fails.

Libvirt specifies explicitely the environment for the command :
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/sbin:/bin QEMU_AUDIO_DRV=none /usr/bin/qemu-system-x86_64 ..lots-of-other-args...

Actions #1

Updated by Julien Desfossez over 8 years ago

  • Status changed from New to Resolved

It turns out, the problem was caused by apparmor, not UST.

Actions

Also available in: Atom PDF