Project

General

Profile

Bug #826

Cannot enable-event twice even if tracing stopped.

Added by Christian Babeux over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Target version:
Start date:
08/18/2014
Due date:
% Done:

100%

Estimated time:

Description

While playing with JUL I stumbled upon this limitation:

$ lttng create foo
$ lttng enable-event -a -u
$ lttng start
[...]
$ lttng stop
$ lttng view
[...]
#
# Oops can't see JUL events, let's enable JUL domain...
#
$ lttng enable-event -a -j
Error: Events: Tracing already started (channel channel0, session foo)
Error: Command error

Is this an expected behavior?

#1

Updated by David Goulet over 5 years ago

  • Status changed from New to Confirmed
  • Assignee set to David Goulet
  • Priority changed from Normal to High
  • Target version set to 2.4
#2

Updated by David Goulet over 5 years ago

  • Status changed from Confirmed to Feedback

So this is because with "-a -j", we need to enable a new channel but a new channel CAN NOT be enabled after start. This is a limitation from the tracer.

I'm not sure how to fix that except a better error message?

#3

Updated by Christian Babeux over 5 years ago

  • Assignee changed from David Goulet to Christian Babeux
#4

Updated by Christian Babeux over 5 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Applied in changeset tools|commit:45d5d421f3464b541315509ecc2295be81b7139d.

Also available in: Atom PDF