Project

General

Profile

Actions

Bug #83

closed

Document bug statuses

Added by Yannick Brosseau almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Start date:
02/20/2012
Due date:
% Done:

0%

Estimated time:

Description

Currently, the usage of each bug status is not consistent among them members.


Related issues

Precedes Website - Feature #138: Workflow graph for bug statusesNewRaphaƫl Beamonte02/29/2012

Actions
Actions #1

Updated by Anonymous almost 10 years ago

  • Status changed from New to Feedback

I quickly drafted https://bugs.lttng.org/documents/2 (a Document in the Website project) to put down in writing what me and David discussed last week. Comments welcome!

Actions #2

Updated by Yannick Brosseau almost 10 years ago

Bugs statuses from Ubuntu:
https://wiki.ubuntu.com/Bugs/Status

Actions #3

Updated by Anonymous almost 10 years ago

Yep, I read that page. It gives some good ideas, but I don't think we should mimic Ubuntu's statuses 1-to-1.

First of all, LTTng is a much smaller project, with a smaller user base and a MUCH smaller dev team. Ubuntu has some statuses we don't really need (we can merge Opinion/Invalid). We can also merge Fix Committed and Fix released (as Resolved), since the Fix Released status is handled automatically by Launchpad.

Another key difference, "Confirmed" for us should, or so I think, only be confirmed by other developers and not necessarily by another user. Not that I don't trust other users, but since the scope is much smaller I think (the union of) the developers can go over all the bugs, so "Confirmed" would mean that at least one developer looked at it.

Actions #4

Updated by Yannick Brosseau almost 10 years ago

It's was just a reference to what others are doing, not necessary a suggestion!

Actions #5

Updated by Anonymous almost 10 years ago

  • Status changed from Feedback to Resolved

We'll go with what we have now, it might be updated depending on the result of #138.

Actions

Also available in: Atom PDF