Project

General

Profile

Actions

Bug #906

closed

Enabling events in two agent domains corrupts the model

Added by Philippe Proulx almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Target version:
Start date:
08/22/2015
Due date:
% Done:

100%

Estimated time:

Description

Steps:

lttng create a
lttng enable-event -p a,b,c
lttng list a

Everything okay so far:

=== Domain: Python (logging) ===

Events (Logger name):
---------------------
    - a [enabled] (loglevel: PYTHON_DEBUG)
    - c [enabled] (loglevel: PYTHON_DEBUG)
    - b [enabled] (loglevel: PYTHON_DEBUG)

Enable one event in a second agent domain:

lttng enable-event -j d
lttng list a

Result:

=== Domain: JUL (Java Util Logging) ===

Events (Logger name):
---------------------
    - a [enabled] (loglevel: UNKNOWN)
    - c [enabled] (loglevel: UNKNOWN)
    - b [enabled] (loglevel: UNKNOWN)

=== Domain: Python (logging) ===

Events (Logger name):
---------------------
    - a [enabled] (loglevel: PYTHON_DEBUG)
    - c [enabled] (loglevel: PYTHON_DEBUG)
    - b [enabled] (loglevel: PYTHON_DEBUG)

It looks like events from the first domain (Python) are copied to the second domain (JUL) and the JUL events get an UNKNOWN log level.

The other way around does the same:

lttng create a
lttng enable-event -j jul
lttng list a
lttng enable-event -p python
lttng list a

Result:

=== Domain: Python (logging) ===

Events (Logger name):
---------------------
    - jul [enabled] (loglevel: UNKNOWN)

=== Domain: JUL (Java Util Logging) ===

Events (Logger name):
---------------------
    - jul [enabled] (loglevel: JUL_ALL)

It might be just a listing problem, because I cannot disable the Python jul event here:

Error: Event jul: UST event not found (channel channel0, session a)

However, I can disable the JUL jul event, and both seem disabled afterwards:

=== Domain: Python (logging) ===

Events (Logger name):
---------------------
    - jul [disabled] (loglevel: UNKNOWN)

=== Domain: JUL (Java Util Logging) ===

Events (Logger name):
---------------------
    - jul [disabled] (loglevel: JUL_ALL)

I'm using:

lttng (LTTng Trace Control) 2.8.0-pre - Herbe à Détourne - v2.7.0-rc1-75-g2137586
Actions #1

Updated by Jérémie Galarneau almost 9 years ago

  • Status changed from New to Confirmed
  • Assignee set to Jérémie Galarneau
  • Target version set to 2.7
Actions #2

Updated by Jérémie Galarneau over 8 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Applied in changeset tools|commit:1dfd9906a04873e9d381bf559eb8551c203c8a2a.

Actions

Also available in: Atom PDF