Project

General

Profile

Bug #949

error reporting when kernel tracing not available because of a version mismatch between tools and modules

Added by Julien Desfossez over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
10/09/2015
Due date:
% Done:

0%

Estimated time:

Description

If lttng-modules and lttng-tools versions don't match, an error is only reported when starting the sessiond, after that all commands seem to succeed but fail silently.
So if the sessiond is started by a startup script, the user never knows kernel tracing is not working.

Also, the error message is not very accurate: "Error: Kernel tracer ABI version (2.0) is not compatible with expected ABI major version (1.*)"

root@asdf:~# lttng create
Session auto-20151008-092032 created.
Traces will be written in /home/asdf/lttng-traces/auto-20151008-092032
root@asdf:~# lttng enable-event -k -a
All Kernel events are enabled in channel channel0

this should fail ^

#1

Updated by Jérémie Galarneau almost 4 years ago

  • Target version set to 2.8
#2

Updated by Jérémie Galarneau almost 4 years ago

  • Status changed from New to Resolved

I can't reproduce on stable-2.8 and master. However, the error messages should now be clearer.

Also available in: Atom PDF