Project

General

Profile

Bug #973

Failure when loading saved live session

Added by Li Liguang over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Low
Target version:
Start date:
11/05/2015
Due date:
% Done:

100%

Estimated time:

Description

How to reproduce:
1) lttng-relayd -d
2) lttng create s1 --live 1000000
3) lttng enable-event -u -s s1 -c channel0 hello_world:my_first_tracepoint
4) lttng save
5) lttng destroy
6) lttng load
Error: URL already exists

Problem analysis:
When creating session, i think there is no need to judge the variable jul_domain and log4j_domain in the create_session function.

#1

Updated by Jonathan Rajotte Julien over 4 years ago

  • Status changed from New to Confirmed
#2

Updated by Jonathan Rajotte Julien over 4 years ago

  • Status changed from Confirmed to Feedback
  • Assignee set to Jonathan Rajotte Julien
  • Priority changed from Normal to Low
  • Target version set to 2.8

Hi Li,

See https://github.com/lttng/lttng-tools/pull/56 for a possible fix.

Could you provide some feedback on your end?

It might need some discussion with Jeremie[jgalar] (Lttng-tools maintainer) since the URL ownership is not clear (is it session specific or we might want to make it domain specific?).

Thanks for the bug report! Keep them coming :)

Cheers!

#3

Updated by Li Liguang over 4 years ago

Hi,

I've tested this patch and it works.

Regards,
Li

#4

Updated by Jérémie Galarneau about 4 years ago

  • Status changed from Feedback to Confirmed
  • Assignee changed from Jonathan Rajotte Julien to Jérémie Galarneau
#5

Updated by Jérémie Galarneau about 4 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Applied in changeset tools|commit:95681498599cbd3bc1aa6dfa725a668ab272170b.

Also available in: Atom PDF