Project

General

Profile

Bug #970

snapshot written in 2 folders if it takes more than 1 second to record

Added by Julien Desfossez over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Target version:
Start date:
11/03/2015
Due date:
% Done:

100%

Estimated time:

Description

With "lttng snapshot record" on a session with UST et kernel buffers, if the writing of one domain takes longer than 1 second, another folder is created when writing the data of the second domain.
Reproduced with master.

lttng create --snapshot
lttng enable-channel -k bla --subbuf-size 8M --num-subbuf 8
lttng enable-event -k -a -c bla
lttng enable-event -u -a
lttng start
... wait for the kernel ring-buffer to be full...
lttng snapshot record

If the disk takes longer than 1 second to write 64MB, the resulting snapshot looks like this:

ls /home/julien/lttng-traces/auto-20151103-174410
snapshot-1-20151103-174443-0/kernel/.....
snapshot-1-20151103-174446-0/ust.....

This is confusing because we expect all the traces of one snapshot to be in the same folder, especially when we record lots of them it becomes a mess to link the ones that belong together.

Also available in: Atom PDF