Project

General

Profile

Feature #334

Display configured filter

Added by Bernd Hufmann over 7 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Target version:
Start date:
09/13/2012
Due date:
% Done:

0%

Estimated time:

Description

LTTng Tools 2.1.0 offers the ability to configure filter when enabling events. It currently displays only that a filter is configured for command "lttng list <session>". It would be beneficial also to display the actual filter expression in the command output instead of displaying only [with filter].


Related issues

Related to LTTng-tools - Feature #630: 'lttng list session_name' should list the filters attached to the eventsResolved09/11/2013

Actions
#1

Updated by David Goulet over 7 years ago

  • Status changed from New to Confirmed
  • Target version set to 2.2

Since we are in RC mode right now for 2.1.x, I am tagging this feature request for 2.2.

Thanks

#2

Updated by David Goulet about 7 years ago

  • Target version deleted (2.2)
#3

Updated by Christian Babeux about 6 years ago

  • Assignee set to David Goulet
  • Target version set to 2.5
#4

Updated by David Goulet about 6 years ago

  • Assignee deleted (David Goulet)
  • Priority changed from Normal to Low
  • Target version changed from 2.5 to 2.6

I'm moving this feature for 2.6 unfortunately.

We are quite close to the rc1 of 2.5 and I feel uncomfortable adding this right now since it requires a lot of code and adding stuff to the public ABI/API. I usually prefer changes on the API done way before so people can play with it and we can make adjustment instead of rushing it.

I've started a branch containing some code for the feature but it's not working at all for now.

https://github.com/dgoulet/lttng-tools-dev/tree/bug334

#5

Updated by Jonathan Rajotte almost 6 years ago

Just let me know when this is slowly getting to work. I'll match the MI as soon as possible. Don't hesitate to open a bug and assign it to.

#6

Updated by Jérémie Galarneau over 4 years ago

  • Target version changed from 2.6 to 2.8
#7

Updated by Jonathan Rajotte Julien about 4 years ago

  • Status changed from Confirmed to Resolved

Starting from 2.8 the filter expression is available on the command line and the mi.

E.g

Buffer type: per UID

Channels:
-------------
- channel0: [enabled]

    Attributes:
      overwrite mode: 0
      subbufers size: 131072
      number of subbufers: 4
      switch timer interval: 0
      read timer interval: 0
      trace file count: 0
      trace file size (bytes): 0
      discarded events: 0
      lost packets: 0
      output: mmap()

    Events:
      * (type: tracepoint) [enabled] [filter: 'test']

<events>
  <event>
    <name>*</name>
    <type>TRACEPOINT</type>
    <enabled>true</enabled>
    <filter_expression>test</filter_expression>
    <exclusions/>
  </event>
</events>

Cheers

Also available in: Atom PDF