Project

General

Profile

Bug #135

Documentation should mention that lttng_event must be initialized to 0 to use the default values

Added by Raphaël Beamonte over 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Target version:
Start date:
02/28/2012
Due date:
% Done:

100%

Estimated time:

Description

If we do not initialize the struct lttng_event to 0, the lttng sessiond might return a fatal error when executing (if the value of the loglevel_type is set to an unknown value).
Documentation should mention that we can (have to ?) initialize to 0 the structure with :

struct lttng_event event = {0};

Or

struct lttng_event event;
memset(&event, 0, sizeof(struct lttng_event)));

#1

Updated by David Goulet over 8 years ago

  • Status changed from New to Confirmed
  • Assignee set to Raphaël Beamonte

This is actually safer since this data is passed over the network and zero is "normally" uninitialized values.

However, the lttng ctl API enable-even should check mandatory field before sending it back to the session daemon and as of today, the loglevel check is not there.

Feel free to send a patch for developer documentation and loglevel check in liblttng-ctl enable-event call.

#2

Updated by Yannick Brosseau about 8 years ago

Should mention that all struct should be initialized to zéro before use

#3

Updated by Anonymous about 8 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF